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Picking
Berries With TRADOS
By Tuomas Kostiainen

Using TRADOS is like

picking berries in a Finnish forest. If
you know the forest and where to find
the best berry patches, you will do fine
and get a lot of berries in no time
without getting lost. However, if you do
not know your way around or even what
to look for, you will end up without
berries, frustrated, lost, or perhaps even
worse, harassed by a bear. Rather than
risk this plight, many choose to stay
close to the forest’s edge, making do
with the berries they find there.
While teaching TRADOS workshops and providing one-on-one
training, I have noticed that many
translators tend to stay within the
periphery of the first useful functions
they encounter, unsure of how to venture into what they perceive as a forest
of options to get to the more advanced
features TRADOS has to offer (the
very best berry patches). “Oh, I don’t
know where to go,” or “I can’t read
the map,” they say. I realize that as a
trainer, my job is not to teach everything that TRADOS does, but to tell
workshop participants about the best
berry patches and draw a useful map
so that everyone can get there and
back, directly and safely. So, here is
my collection of some of the best features TRADOS has to offer, along
with a map for finding them.

Memory or Memories?
Many (if not most) translators use
several different translation memories
(TMs), creating a separate memory for
each client or subject. While there
might be some good reasons for this
approach in certain situations, I find it

much more efficient to use one large
memory with attribute fields (such as
“client” and “subject”). This allows
you to utilize all of the previous translations you have done for other clients,

the “Attribute and Text Field
Differences Penalty” option in
TRADOS (Options > Translation
Memory Options > Penalties) gives
priority to TUs that have the same

Having a large number of client- or subject-specific
memories defeats, to some extent, one of the main
purposes of using a TM tool like TRADOS.
or those covering a particular subject.
Having a large number of client- or
subject-specific memories defeats, to
some extent, one of the main purposes
of using a TM tool like TRADOS.
Some programs, such as Déjà Vu,
allow you to use several memories at
the same time, but TRADOS does not
(except for concordance searches,
which I will explain later). Combining
everything into one large memory
does not have to be as messy as it
sounds, just as long as you classify
your translation units (TUs) according
to client, subject matter, project
number, and/or any other attribute or
text field you might find useful.

Using Attribute Fields
Attribute and text fields (together
called TM fields) can be used as selection criteria when searching a TM
during a translation or when performing memory maintenance. How,
you ask? Just bear with me while I take
you a little deeper into the forest—it
should all make sense in a minute.
For example, during translation,

attribute/text field values as your current project by “penalizing” (= lowering) the fuzzy match levels of all
other TUs by two percentage points
per field (this is the default value, so
you do not need to do anything to set
this up).
For utilizing attribute/text fields in
concordance searches, you can select
the “Apply Current Filter Settings”
option (Options > Translation
Memory Options > Concordance) if
you want to give a priority to TUs that
have specific attribute/text field
values. And as I mentioned earlier,
these fields can also be used while
performing memory maintenance as
filter criteria when you want to utilize
find and replace operations or export a
certain subsegment of your TM, for
example (File > Maintenance >
Filter…).
Here is an example of how to set
up attribute fields and their values
(see Figure 1):
1. In TRADOS Workbench, select
“File > Setup… > Fields.”

➡
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Picking Berries With TRADOS Continued

Figure 1: Fields tab open for adding text fields and attribute fields and their values.

Selecting the Appropriate Fields
The only downside to using
attribute/text fields is that you have to
remember to select the appropriate
fields and their values before each
new project. The selection is done as
follows (see Figure 2):
1. In TRADOS Workbench, select
“Settings > Project and Filter
Settings.”
2. Select appropriate attribute/text
fields and their values for project
settings and filter settings. Note the
difference between the two:
• Project settings define the fields
and their values that will be
added into each new TU.
• Filter settings define the fields
and their values that will be used
as filters when searching the TM
during translation.

2. Select any field in the “Attribute
Fields” list.
3. Click “Add” and type a new name
(such as “Subject”) into the “Field”
input box. You now have a field
called “Subject.”
4. Select “Subject” in the “Attribute
Fields” list and then “A Value”
from the “Attribute Values” list.
5. Click “Add” and type a new name
(such as “Medical”) into the
“Field” input box. You now have
an attribute field called “Subject”
containing one value called
“Medical.” Repeat this for additional fields and their values.
6. When you have added all fields and
their values, click “OK” (do not
click “Add” at this point anymore).
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Using Text Fields
Text fields function differently, in
the sense that you set only the text
fields but not their values in advance,
and then write the needed value in the
“Project and Filter Settings” dialog
box (see Figure 2). An example of a
text field could be a project number or
another piece of information that is
used only once. A project number is
used only for that project, but a subject name (= attribute field) will be
used every time you translate for that
subject.
If you have not yet used attribute
and text fields, it is worth spending a
few minutes to figure out what type of
field structure would be most useful in
your case. Two or three attribute fields
could be enough, such as subject and
client. Of course, you can add new
fields and their values later.

3. You can get the “Project and Filter
Settings” dialog box to appear
automatically every time you open
TRADOS or a new memory by
selecting “Options > Translation
Memory Options > General >
Show Project Settings” (you need
to do this only once).
4. Remember to change your project
and filter settings if you start working
on another translation project without
closing the TM or TRADOS.
5. Also, remember to verify your current project and filter settings before
doing an analysis or clean up.
Sounds like a hassle? Yes, a little,
but it pays off quickly. It is like using
mosquito repellent in the woods—a
hassle, yes, but you will be happy
you did.
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Figure 2. Selecting project and filter settings for a
translation project before starting a translation. Selected
fields and their values are listed in the “Current settings”
box.

Segmentation Rules
TRADOS uses so-called segmentation rules to segment the source text.
By default, segmentation rules are
based on punctuation marks so that a
segment is normally equivalent to one
sentence. This works fine in most situations, and one rarely needs to
bother with these rules. However,
there are situations where adjusting
them slightly can make your work
much more efficient.
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Using Stop Characters: I have translated numerous ingredient lists for various products (pet food, nutritional
supplements, etc.) where each list
often includes pretty much the same
ingredients, but in a different order. If
you translate these lists using default
segmentation rules, each list is treated
as one translation unit, and you end up
translating each ingredient again and
again without benefitting from your
previous translation. However, if you
include a comma or semicolon
(depending on which one is used to
separate the ingredients on the list) as
a “stop character,” you can translate
these lists ingredient by ingredient. As
a result, by the time you start working
on the second ingredient list, you will
get many 100% matches. You will also
not have to figure out how to translate
“partially hydrolyzed organic Baltic
herring liver oil” or retype it again (see
Figure 3).
Changing Segmentation Settings: To
change the settings, go to “File >
Setup… > Segmentation Rules.” You
can either create a new category for
your stop character (such as a comma
or semicolon) or just add it under
“Marks” together with the question
mark and exclamation point that are
already there. The “Segmentation
Rules” dialog box might look a bit confusing, but do not be too afraid to play
with it. With the Reset “panic button”
you can easily reset the default settings,
and no harm has been done.
Overriding Segmentation Settings:
One easy but often overlooked feature
you can use during translation to override the segmentation rules is the
“Expand Segment” (Ctrl+Alt+Page
down)
or
“Shrink
Segment”
(Ctrl+Alt+Page Up) command. This is
very handy when you want to translate
two source sentences as one target

sentence or when TRADOS does not
recognize a period at the end of a sentence as a segmentation mark (because
there is a number or unknown abbreviation right before the period). In such
situations, the segment that is opened
for translation consists of two sentences. You can expand or shrink a
segment by repeatedly selecting the
respective command as many times as
you need to, and the segment
expands/shrinks each time to the
next/previous segmentation mark.

In Love With the New TRADOS
MultiTerm
If you got frustrated with
MultiTerm Version 5 and have not
tried it since, you should take a look at
the newer version of iX or 7. The new
versions are much easier to use, and
they have made it very simple to add
new terms to a MultiTerm glossary
directly from Word or TagEditor
while translating. I use this often to
add long product names to a glossary—not so much to build a longterm glossary, but to make it easy to
copy these long names into my translation with a simple “Alt+Arrow”
keyboard command without having to
retype the entire name.
Another handy idea is to maintain a
termbase of common long words and
expressions, such as “turn right,” “counterclockwise,” and “immediately.” This
could be used for the same purpose as
MS Word’s AutoCorrect function (see
the article by Clifford Landers in the
June 2006 issue of The ATA Chronicle,
pages 26-28), but the nice thing about
this is that you do not have to memorize
anything, because MultiTerm remembers the terms for you.
Converting your old MultiTerm 5,
Word, or Excel glossaries to
MultiTerm 7 termbases is still a much
more complicated process than it
should be. However, it is not dif- ➡
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Figure 3. Segmentation Rules tab open for adjusting segmentation rules. Here, a comma has been added as a “stop
character” in the “Marks” category to allow translation from comma to comma.

ficult if you know what to do. In case
you do not, you can download my
Quick Guide to MultiTerm iX/7 from
www.finntranslations.com/trados
help.html. It includes simple, straightforward instructions on how to convert and exchange glossaries and how
to add terms directly from Word and
TagEditor to a MultiTerm termbase
(i.e., the basics you need to know in
order to use MultiTerm efficiently
with TRADOS).

Substitutions
In addition to the default substitution of numbers, dates, and measurements, TRADOS also offers two
non-default substitution possibilities
(see Figure 4).

Figure 4. Substitutions tab open for selecting automatic substitutions. Variable names in the “Variable list” will be
treated as placeables during translation.

Acronyms Substitution: The “Acronyms Substitution” setting (File >
Setup… > Substitutions > Acronyms)
becomes handy when you are
working, for example, on software or
hardware interface instructions where
software commands or names of buttons and switches are written all in
capital letters and do not need to be
translated. When “Acronyms” is
selected on the “Substitutions” tab,
TRADOS treats all words written in
caps as placeables, and substitutes
them automatically. For example,
“Select SEGMENTATION RULES
Tab” would be a 100% match after
“Select ACCESS RIGHTS Tab” has
been translated.
Variables Substitution: The other
substitution option that everyone
should be using is called “Variables”
(File > Setup… > Substitutions >
Variables). With this you can define
words that do not need to be translated,
such as proper names, by adding them
to the “Variable List” box. All of these
words will then be treated as placeables during translation, and it is very
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easy to add them to the text using the
“Add Placeable” commands without
ever again having to retype them.

Useful Links

Not Fuzzy Enough
You just translated a similar sentence or phrase, but cannot figure out
why it will not come up as a fuzzy
match. Try lowering your “Minimum
Match Value %” setting from the
default 70% down to 50% or 40%.
These lower level fuzzy matches often
include useful phrases and terms. You
will also get some useless matches, but
they do not cost you anything—you
can just ignore them. To change the
setting, select “Options > Translation
Memory Options > General.”

Using Reference TM for
Concordance Searches
As I mentioned earlier, TRADOS
allows you to have only one TM open
at a time for translation, but you can
use a second memory for concordance
searches. Reference (read-only)
memory for concordance is a handy
way to utilize a second TM. You can
set TRADOS so that every concordance search is also done in the reference translation memory in addition to
the active translation memory. If you
select “Search First in Reference
Translation Memory,” the search is
done first in the reference TM and then
in the active TM (if there were no hits
in the reference TM). Otherwise, the
search is done first in the active TM. To
select the reference TM and change the
setting, select “Options > Translation
Memory Options > Concordance.”

Microsoft Glossaries
If you have been reading Jost
Zetzsche’s excellent Tool Kit newsletter
(www.internationalwriters.com), you
know about the new arrangement with
Microsoft glossaries. The applicationspecific “glossaries,” which were more
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www.apsic.com
ApSIC Xbench: for searching and viewing bilingual files, such as MS glossaries.
ApSIC Comparator: for comparing edited and unedited files, such as TagEditor files.

www.finntranslations.com/tradoshelp.html
Quick Guide to MultiTerm iX/7, along with other workshop and presentation handouts.

www.globalready.com
MSGloss2TWB for converting MS glossaries to TRADOS TM.

www.internationalwriters.com
Jost Zetzsche’s Tool Kit newsletter.

www.microsoft.com/globaldev/tools/MILSGlossary.mspx
The new Microsoft terminology translations link.

http://sdl.custhelp.com
The SDL/TRADOS support page.

like translation memories, have been
replaced by a real glossary of 9,000
English terms, plus their translations in
up to 45 different languages. The previous glossary files are now available
only to paying subscribers, so do not
lose your old files if you still have
them.
I have often been asked how to use
Microsoft glossaries with TRADOS and
MultiTerm. Here are some suggestions.
First, convert those old glossary
files into a TRADOS TM. One simple
way to do it is through a free utility
called MSGloss2TWB (www.globalready. com). Depending on the language, this memory can have
hundreds of thousands of TUs and can
be very useful if you translate any soft-

ware-related texts. This is one of the few
memories I keep separate from my main
TM, and I use it often as a reference
memory for concordance searches.
Unfortunately, the MSGloss2TWB
program does not have an option to
include attribute fields in the resulting
memory, but you can add them quite
easily in TRADOS using the “Find
and Replace” function.
1. First, you need to set up the fields
and their values if they do not
already exist in the memory, as
described earlier (see Figure 1).
2. Go to “File > Maintenance…>
Find and Replace > More,” select
the attribute field(s) and the ➡
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value(s) you want to add from the
picklist(s).
3. Select “Merge” and click “OK.”
4. Select “Begin Search” to view the
first few TUs that will be changed.
5. Select “Change”
Translation Units.”

and

“All

If you want to test your find and
replace operation, select the
“Translation Units in Current List”
option instead. That way the change
will only be applied to those TUs in
the list, and you can verify the effect
of the operation before applying it to
the entire memory. You can also do
this with a set of proper find and
replace commands in a good text
editor (such as UltraEdit), or even in
Word (Notepad is too slow for this)
before importing the .txt files to a TM.
Another handy and equally cheap
way to utilize these files is another
free utility called ApSIC Xbench

Attention
Exhibitors

(www.apsic.com). It does not allow
you to import the files into a
TRADOS TM, but it provides a powerful and convenient way to search
and view bilingual information, such
as the old Microsoft glossary files,
outside of TRADOS.
The old Microsoft glossary files
are not suitable for use in MultiTerm
because they mostly consist of whole
sentences or paragraphs of text.
MultiTerm needs a proper glossary of
terms or short phrases. Years ago, the
Microsoft glossary package used to
include a “Glossary of Standard
Terms” of over a thousand general
terms, which made it a very useful
source for a MultiTerm glossary.
However, this file has not been a part
of the package for many years. Maybe
you still have it from some old download. The file name is xx_stand.csv
(“xx” indicates a language code).
Anyhow, the new free 9,000-term
glossary file also suits this purpose
very well, but you might first want to
delete all the languages you do not

ATA’s 48th Annual Conference

•

San Francisco, California

need to make the conversion faster.
The conversion is done with
MultiTerm Convert and by selecting
Excel as the source file type. You can
find detailed instructions in my Quick
Guide to MultiTerm iX/7.

In and Out of the Woods
I hope these few suggestions and
examples have given you the courage
and knowledge to venture deeper into
the TRADOS environment and start
picking even juicier and bigger
berries. If, in spite of it all, you end up
getting lost, remember that every
TRADOS dialog box has a “Help”
button that opens online help for that
particular dialog box. Just stay calm
and read the instructions. The bears?
Yes, they are out there, but do not
worry. Just play dead, or are you supposed to run away, or is it act big and
aggressive…? Hmm, I need to check
on that.

•

October 31-November 3, 2007

Plan now to exhibit at ATA’s 48th Annual Conference in San Francisco,
California, October 31-November 3, 2007. Exhibiting at ATA’s Annual
Conference offers the best opportunity to market your products and services
face-to-face to more than 1,500 translators and interpreters in one
location. Translators and interpreters are consumers of computer
hardware and software, technical publications and reference
books, office products, and much more.
For additional information, please contact Matt Hicks,
McNeill Group Inc.; mhicks@mcneill-group.com;
(215) 321-9662, ext. 19; Fax: (215) 321-9636.
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